Tennessee Car Forums at TennSpeed banner

1 - 20 of 27 Posts

·
Krispy Kreme Addict
Joined
·
7,450 Posts
Discussion Starter · #1 · (Edited)
ok so i just got done rebuilding my d15b7 about a week ago and then took it on a trip to AL (about 600mi round trip) to rack up some mileage for the break in period (btw how long is the break in period and how low do i need to keep the rpm's?) anyway i came back the day before yesterday and then tried to start it yesterday and got nothing.... so i have checked the following:
-there is spark
-there is fuel as i have pulled the plugs and smelled and felt gas on them
-checked the engine fuse up front and it is good
-valve timing is good; it lines up
-rotated the dizzy all the way to the right and left and still nothing
-SOUNDS like compression is good but idk for sure.
Im all out of ideas. Am i missing something or what? Hope you guys can help me out...the thing that throws me off is that i sprayed starting fluid just to see if it would at least start on that but still nothing...all it does now is turn over
... any help would greatly be appreciated
TIA!!!
 

·
TRY HARDER
Joined
·
2,901 Posts
Check the ground on the trans, block and head....also check to make sure it didnt jump a tooth on the cam gear not because you didnt do it right but sometimkes the tensioner like to gives slack when they feel like it on D motors. Check all that then pull the Distributor cap off and make sure that its on the number one when its at T.D.C. Also just drive it normal for a good thousand mi. Then I think you might be able to give it hell...
 

·
Krispy Kreme Addict
Joined
·
7,450 Posts
Discussion Starter · #3 ·
Check the ground on the trans, block and head....also check to make sure it didnt jump a tooth on the cam gear not because you didnt do it right but sometimkes the tensioner like to gives slack when they feel like it on D motors. Check all that then pull the Distributor cap off and make sure that its on the number one when its at T.D.C. Also just drive it normal for a good thousand mi. Then I think you might be able to give it hell...
not sure where the grounds are...pics of you have 'em...and already checked the cam gear...ill try the dizzy thing too
 

·
Krispy Kreme Addict
Joined
·
7,450 Posts
Discussion Starter · #4 ·
dizzy is good... its lined up
 

·
yes i'm RICE
Joined
·
3,689 Posts
sometime smelling the spark plug,dont help,i say if you get spark and gas
it shoulder of start,so check make sure the fuel pump is working,what i do
is squeeze the fuel line and let someone turn the key,(tel the light turn on)
if you feel something then the fuel pump is good,
 

·
yes i'm RICE
Joined
·
3,689 Posts
sometime smelling the spark plug,dont help,i say if you get spark and gas
it shoulder of start,so check make sure the fuel pump is working,what i do
is squeeze the fuel line and let someone turn the key,(tel the light turn on)
if you feel something then the fuel pump is good,
 

·
Krispy Kreme Addict
Joined
·
7,450 Posts
Discussion Starter · #7 ·
sometime smelling the spark plug,dont help,i say if you get spark and gas
it shoulder of start,so check make sure the fuel pump is working,what i do
is squeeze the fuel line and let someone turn the key,(tel the light turn on)
if you feel something then the fuel pump is good,
ill try that... its just that it didnt even start when i put starting fluid in there... thats whats throwing me off...:cussing:
 

·
Krispy Kreme Addict
Joined
·
7,450 Posts
Discussion Starter · #8 ·
anybody? is there some kind of switch or plug that would do something like this?
 

·
Internet Warrior
Joined
·
5,476 Posts
anybody? is there some kind of switch or plug that would do something like this?
if you were running too small or large of a gap this could occur, but since you've been driving your car i'd factor those out. try a leakdown or a compression test to see what the results are.
 

·
Banned
Joined
·
163 Posts
your sure you dont have a bad fitv or iacv or bad vaccum leak. those will cause the motor to have a hard time starting when cold and sometimes make it not start at all
 
Joined
·
931 Posts
if it was the fitv he could completely bypass it and the iacv might need a cleaning but wouldnt stop it from starting
amed hit me up tommorrow night ill try and find a way out there and help ya out
 

·
Banned
Joined
·
163 Posts
just cover throttle body with your had and have someone try to start it and if it starts its one of the three i told you. and also when you turn they key to on is your check engine light comen on, if not your ecu is bad. also simce no one has told you the grounds yet theres 3 main ones, valve cover, thermostat housing on rear of motor and on trans
 

·
Krispy Kreme Addict
Joined
·
7,450 Posts
Discussion Starter · #13 ·
if it was the fitv he could completely bypass it and the iacv might need a cleaning but wouldnt stop it from starting
amed hit me up tommorrow night ill try and find a way out there and help ya out
done

just cover throttle body with your had and have someone try to start it and if it starts its one of the three i told you. and also when you turn they key to on is your check engine light comen on, if not your ecu is bad. also simce no one has told you the grounds yet theres 3 main ones, valve cover, thermostat housing on rear of motor and on trans
nope. still nothing. CEL is on. all grounds are grounded. im totally stumped lol
 

·
X Honda Junkie
Joined
·
2,907 Posts
so do you have fuel and spark??? if so check timing again might have jumped a tooth
 

·
X Honda Junkie
Joined
·
2,907 Posts
sorry just read first post. just turn the key and you should hear the fuel pump run if not then check relay and fuel pump. i have had a relay act crazy on me before. flaking in and out so it will squirt but not enough to get the car started. check ground from the baattery to the car if this is lose it will not start either but the starter will still spin.
 

·
Krispy Kreme Addict
Joined
·
7,450 Posts
Discussion Starter · #17 ·
sorry just read first post. just turn the key and you should hear the fuel pump run if not then check relay and fuel pump. i have had a relay act crazy on me before. flaking in and out so it will squirt but not enough to get the car started. check ground from the baattery to the car if this is lose it will not start either but the starter will still spin.
you sure your dizzy is good. i had one one that was bad but when i pulled plug out and checked it it sparked. just wouldnt spark over and over
-heard fuel pump on. Relay is good
-plenty of gas gettin in there. plugs were wet when i pulled 'em
-all grounds are good.
- had my bro check the sparks while i started and they sparked over and over.

im pulling my hair out on this one. Never seen anything like this b4...:dickeled:
 

·
Official Slow Member
Joined
·
1,857 Posts
ok so i didnt feel like reading everyones responses..
but!!!

after i did my swap...
one day.. my car wouldnt start..
so i was thinking ab things i tinkered with during the swap.
so i thought... DIZZY!!!
i took the cap and rotor off.
and looked...
one of the wires on the coil pack came just slightly loose!
my car was turning over but wasnt starting...
so i tightened the little screw holding the down and it started up perfectly.
so check your dizzy.
it could be old and the control modules could be worn out.
try putting another dizzy on and see what happens.

sounds kinda random... but i thought it was too in my case.
but im just trying to help!
hope you figure it out man!
g/l!
 

·
X Honda Junkie
Joined
·
2,907 Posts
just because it is sparking doesn't mean it is strong enough or at the right time... still check timing you will have to remover the timing covers on the driver side then rotote the motor till the up arrow is pointing up then look at the crank gear and there will be a dot or line on it and there should be a mark on the block too make sure they are lined up. for it not to start up it will have to be 3 teeth or more off normally. jumping timing is kinda common on these motors i know i have seen it atleast a dozen times and i don't even own a d series.
 
1 - 20 of 27 Posts
Top