Tennessee Car Forums at TennSpeed banner
1 - 20 of 30 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter · #1 ·
Hey, so i'm just now getting the car put back together. It's a 92 cx. I'll post up more pics later. Hopefully it'll be a decent thread. This ones the most important though... :wink:
 

·
n00b
Joined
·
695 Posts
how do you expect a car to start with no battery? thats just silly.
 

·
Registered
Joined
·
192 Posts
very clean . im in the progress. jus got mine started earlier today.
 

·
Registered
Joined
·
212 Posts
Discussion Starter · #11 ·
thanks for the compliments guys... :thumbup: I'll post more pics later.

You probably noticed there's no intake on the motor... i'm still debating on what to use. Passwordjdm? AEM? DIY? any opinions are welcome...
 

·
Registered
Joined
·
212 Posts
Discussion Starter · #13 ·
So here are some older pictures of progress.. i'll try to keep them in order. And yea, it did look pretty good there for a while. but i wasn't satisfied w/ my bay or the exterior paint/ dings. so she's nice and ugly for now, and i drive her that way. :mrgreen














 

·
Registered
Joined
·
698 Posts
if you look just under the message body it says add image to post...you click that then press browse...then find the pic...and wait for it to load...if its large it should take about 30 sec
 

·
Registered
Joined
·
698 Posts
i think you can copy and paste the picture's code in the line that says broser(after you click add image to post) 1 at a time
 
1 - 20 of 30 Posts
Top