Tennessee Car Forums at TennSpeed banner
1 - 6 of 6 Posts

·
Registered
Joined
·
954 Posts
Discussion Starter · #1 ·
My 240 has had an issue. My speedometer works fine, just reads double.. I have been told its an s13 speed sensor and I need an s14 one, but not really sure about it. And it costs $212 from Nissan and not that I can't pay for it, I just don't want to spend money I don't have to. My lights are kinda weird too, but I think that's just a wiring issue, or because I have the kouki front end. Anyone have any advice? thanks.
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #3 ·
Yea I think I remember you saying something about that when he was trying to sell it? I guess that's what I'm going to do then, but should I go the Nissan route for $220?
 

·
Registered
Joined
·
341 Posts
1. Go to Zilvia.net
2. Make an account
3. Find one for sale on the cheap
4. Buy one
5. Install
6. Enjoy
 

·
WAT.biz
Joined
·
5,115 Posts
PM bmx Dave on getting one. He gets a discount at Nissan. You can get one through autozone as well but if you go to advance it will be the wrong part number and they will have to get it through Nissan directly. I learned the hard way. Finding an s14 speed sensor on zilvia is a rarity, or it was when I was searching at least. So either PM dave or get it through autozone.
 

·
Registered
Joined
·
522 Posts
Or if your a ganster you can change the setup on the cluster so your speed reads right, your mileage though will still increase x2.
Freshalloy has a thread on converting a JDM cluster to read MPH, same principle except your adjust mph to mph so the precents your using in that thread are changing the cluster by 1.6X instead of a 1:1 ratio.
I had to do this on my S14 with a 300ZX sensor on a 300ZX transmission
-James
 
1 - 6 of 6 Posts
Top