Tennessee Car Forums at TennSpeed banner
1 - 20 of 126 Posts

·
International Administrator
Joined
·
9,619 Posts
Discussion Starter · #1 ·
Well people here know me, and that i cant leave anything alone for very long. It's come time for me to build a project to keep me busy, its been a few yrs since the red teg. The other side project is on hold for now also....it's hard to find a good GN.

Here are a few pics of the parts i got in the mail today...all rev valvetrain for lift upto 14.5 mm, all dual springs, seats, valves, new bronze guides (supertech) and seals. The parts will be mated to my ctr head (which darrell has in his hands as we speak) with a clean up mill job and a heavier than stock port job. The choice of cams will be kept secret for a little longer...for research reasons.

You guys have seen the head, i will post up new pics as soon as RPM is finished (flame on) with all the new goodies to go along with the block and the ATI unit....

peace out dudes...i will update with part/pics/article on how to build a honda engine that lives longer than the dyno pulls...












 

·
SCFTW
Joined
·
7,547 Posts
Good2GetBlown said:
Spoolie, where so you host your pics? For some reason your picks never work in my Mozilla... It happens on other forums too... anyone know why?
Those are photobuckets.... you have adblock set to block images or anything?

I have used mozilla for a WHILE, and never had that problem.
 

·
I <3 wheels.
Joined
·
1,756 Posts
Miracle said:
Good2GetBlown said:
Spoolie, where so you host your pics? For some reason your picks never work in my Mozilla... It happens on other forums too... anyone know why?
Those are photobuckets.... you have adblock set to block images or anything?

I have used mozilla for a WHILE, and never had that problem.

lol, I dunno how but it got put on there... You win my +1 of the day.
 

·
SCFTW
Joined
·
7,547 Posts
Good2GetBlown said:
Miracle said:
Good2GetBlown said:
Spoolie, where so you host your pics? For some reason your picks never work in my Mozilla... It happens on other forums too... anyone know why?
Those are photobuckets.... you have adblock set to block images or anything?

I have used mozilla for a WHILE, and never had that problem.

lol, I dunno how but it got put on there... You win my +1 of the day.
Thank me when I return from Iraq with a drive of the Supra... :)
 

·
International Administrator
Joined
·
9,619 Posts
Discussion Starter · #16 ·
i think wife ok'ed the purchase of the crankshaft/rods/slugs today...i think.
the block has to be sent out also....still on the look out for arp studs...hint hint...
 
1 - 20 of 126 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top